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This tutorial is an introduction to Cadence tool for circuit design and simulations. It deals with the
schematic entry of the circuits and their simulations using Cadence tools

® Composer for schematic capture
® Analog Artist Environment for design simulations.

Composer is the tool for schematic entry of the circuit designed. Once the schematic is ready, the
simulations can be done using the Analog Artist Environment.

Logging onto the SUN THIN CILIENTS or any LINUX MACHINES

Creating a working directory

Once logged in successfully, open a terminal window. To do this
Either:
1. Right click on the desktop and select the Open Terminal option.
OR
2. From the Menu click on Applications select Accessories and then select Terminal
(Applications->Accessories->Terminal).

At the prompt within the terminal window: type mkdir Cadwork to create a working directory
named Cadwork. Then enter the directory by typing cd Cadwork at the prompt.

Now you are in the directory Cadwork. Within the Cadwork directory create two other directories:
CMOS065 and NCSU. Use the “mkdir” command to make these two subdirectories. All the work
done will be stored in these subdirectories depending on whether you are using the CMP or NCSU
Design Kits.

Starting Cadence

Depending on the design Kit you are using you will need to change directory into the corresponding
design kit: for an example “cd CMOS065” for the CMP 65 nm Design Kit or “cd NCSU” for the
NCSU design kit. We will use the CMP process as an example from here on and the procedure will
be the same for the NCSU design kit.

Invoking Cadence for the first time: change directory to CMOS065 and issue the command:
/net/ictools/bin/cmos65 (this copies essential files and scripts into your user space within the
CMOS065 subdirectory which will now serve to hold all your work related to the CMP 65 nm
design kit). The command will launch cadence and display the command interpreter window
(CIW) shown below. From here you are able to create your libraries (covered later).

Edit your .cshre file to include the line: setenv PATH "${PATH}:/net/ictools/bin"
The next time you login to use cadence you must be able to issue the command “cmos65” from the
prompt but from the ~/Cadwork/CMOS065/ directory.
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Open the Library manager window, by clicking on the Tools menu and selecting Library Manager
(Tools->Library Manager). This launches the window shown below.
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You will also get a "What's New" window which you can read and then close or minimize.

To get online manuals on the 65 nm design kit type “cmos65doc” at the prompt from within
~/Cadwork/CMOS065 and you will get a window that lists the available manuals. To get Help on
Cadence click the Help Tab and a browser will be launched from which you can search the manuals
for the topic you want to learn about.



Creating a library

The fist task is to create a design library. To create a library, go to
File—New—Library.
The following window opens. Enter the name of your library say tutorial in the text box.

New Library

— Library

Hame tutorial]

Directory
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— Design Manager
(T Use TDM

_JUse No DM

OK | aApply | Cancel Help

If you want to store the library at a different path, enter the name in the path text box.

Next click on the radio button Attach to an existing tech library. This displays a drop down menu
box. From the menu box choose the technology you want to use. In this tutorial we shall use CMP
65 nm process, which is labeled as “cmos065” select this from the list.
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Then click the OK button. This will create a library with name tutorial, attached to CMP’s 65 nm
process..

Look at the Library manager window. This new library created should have an entry under the
column named Library. If this does not show refresh the library manager (View->Refresh).

Creating a cell-view for schematic capture

Once you have created a design library, you can start to put your design into it. In this tutorial we
shall create an inverter.
Now to create a cell-view from the library manager go to

File—>New—Cell-view

— Create New File
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From the drop down menu box of Library name, choose the library you want the current cell-view
to be in. In the present case, it is the tutorial library.

Enter the name of your cell-view say inverter in the text box corresponding to the Cell Name label.
Then choose the Composer Schematic from the drop down menu called Tool. Composer Schematic
is the schematic entry tool (this is the default option).
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Clicking the OK button and this action should open the Composer Schematic editor, which looks
similar to the picture below:
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Get acquainted with the Composer Schematic editor window. On the left side are various shortcuts
to commonly used commands such as: check & save, save, zo0ming in and out, stretch, copy, move, delete,
place component instances, drawing wires, placing ports, etc. These commands and many more can also be
accessed from the menu.



Design Inverter

Now let’s create an inverter in the editor. To create an inverter we need a PMOS transistor, a

NMOS transistor, dc voltage source and ground.

Getting the required components

Click on the instance button on the left or go to Add—Instance. The following windows open.
Click on Browse and then choose the library as cmos065.
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Click on the list item cmos. The list will displays the contents
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Scroll down to select the list item psvtgp and bring the mouse pointer to the editor. You will see a
PMOS transistor. Left-click the mouse on the editor at the position you want to place the pmos
transistor. Notice that the mouse pointer continues to carry an instance of pmos transistor. If you
want more pmos transistor you can place them on your editor. To deselect the instance press Esc.
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Now we need an NMOS transistor. Click on the instance button on the left or go to Add—Instance.
Click on the list item nsvtgp from the list displayed as in the window below
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Click on the list item nsvtgp and place it on the editor as shown
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Now we need the dc voltage source (Vdd) and ground (gnd). The instances of these components
can be found one directory up in Supplies as shown in the picture below.
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Select the item SUPPLIES to reveal the list of supplies shown in the picture below.
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Select the Vdd_inherint item and place on the editor directly above the PMOS device. Select the
gnd_inherit item from the list and place it in the editor. The result is a diagram connected as shown
in the picture below.
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Notice, when the mouse pointer is taken over the component instance, a rectangular dotted outline
appears. If you wish to rotate or flip this component it can be done now. To rotate or flip the
component, click the right mouse button or go to Edit—Rotate (use the shortcut key ‘). The
following window appears. Depending on the requirement the component view can be modified.

~| Rotate |
Hide @ Cancel Help
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Let’s now connect the gate of both nmos and pmos transistor. Select the wire button from the left
of go to Add—Wire (Narrow). Hide the window, which appears by pressing Hide.

—| Add Wire |
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Next click on the gate of the PMOS and take the mouse pointer to the gate of NMOS. Notice the
wire being dragged along with the mouse pointer. Terminate the wire at the gate of NMOS by
clicking on it. Then click on the overlapping terminals of the transistors and drag the wire to the



right. Terminate the wire after some length by double clicking the left mouse button. Make sure to
also connect the bulk of the PMOS to Vdd and that of the NMOS to ground (as shown).
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Next we need to define the input and output of the inverter. Click the Pin button from left or go to
Add—Pin. This window pops up.

—| Add Pin
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Enter the input pin name as Vin and in the text box, select the input from Direction menu box and
press Hide. Place as shown the following window.



=] Virtuoso® Schematic Editing: tutorial inverter schematic _Elx
Cmd: Pin Sel: 0 g

Tools Design Window Edit Add Check Sheet Options Migrate “Design Kit Help

%A R’

mouse L: mousefddPt() M: schHiMousePoplipi ) R: Rotate 90
Use the options form to supply terminal names for the pins.

Again click the Pin button from left or go to Add—Pin. Enter the output pin name as Vout in the
text box, select the output from Direction menu box and press Hide. Place as shown in the window
above. Click the Esc key to deselect the pin option.

Changing the properties of instance

Now let’s make the PMOS transistor width 4 times that of the NMOS transistot.

Click on the PMOS transistor. Notice the appearance of a solid rectangle around it. Now strike the
key ‘q’ or go to Edit—Properties—Object.

The following window opens.
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By default the width of both the NMOS and PMOS transistors are at their minimum of 120 nm for
the 65 nm technology. Normally making the PMOS transistor bigger by 3-4 times leads to a
symmetrically switching inverter i.e. the NMOS and PMOS devices offer similar equal amounts of
the drain currents. In this case though let us keep the PMOS the same minimum width size and
analyze the transient response.

Saving the schematic

Click on the Check & Save button or go to Design— Check and Save or use the shortcut key X to
check the schematic created and to save it. Check the CIW window to see if it has reported any
errors or warnings, if there are any you have to go back and fix them.

Assuming the schematic is free of errors and warnings we proceed with the simulation of the
invertet.

Simulation

For the simulations of the designs we use the Analog Artist Environment tool. Start by going to
Tools—Analog Environment.

This will open the Affirma Artist Circuit Design Environment simulation window, which is shown
below.
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The design should be set to the right Library, Cell and View.

Now go to Setup—Simulator/Directory/Host.

From the window that opens up select the simulation type as spectre (if it is not already set to
SPECTRE) from the drop down menu. Finish by clicking OK.



The next step requires that we tell the simulator where the model parameters are located. Go to
Setup->Model Libraries. ... The window shown below opens.
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Click on Browse and select the file named modellFiles.scs. This file was copied into your
~/Cadwork/CMOS065 directory when you issued the command /net/ictools/bin/cmos65. Click
OK and the Add tab will be highlighted as shown in the window below.
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Now click the Add button to get the window below.
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Finally click OK and you now have successfully pointed the simulator to the correct location of the
model parameters.

The next step is to set up the stimulus. Go to Setup—>Stimulus—Edit Analog. From window that
opens up choose the radio button graphical and click OK
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The window shown below opens. This is the window in which the stimulus to the inverter is
defined. Observe that the input defined as Vin on the schematic is the entry in this window. You
can also find the global input Vdd if you click the Global Sources radio button.



Select the line OFF Vin/gnd! Voltage dc, in the text box. Change the Function to a pulse. And
enter the pulse parameters as shown and click the change button. Observe the input Vin change
from OFF to ON.
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Now go to the global parameters, enable the Vdd input, give it a dc value of 1.0V and click the
change button. Observe Vdd change from OFF to ON. Finish by clicking OK.

Next we have to give the type of analysis to be performed. Let us perform a transient analysis for

12ns. So go to Analysis—Choose or click the second button on the right of the window. Click the
transient analysis radio button and enter the stop time as 12n. Finish by clicking OK.
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Now we have to choose the outputs to be plotted in the waveform viewer.

Go to Outputs—To be plotted—Select on schematic.

Then bring the editor window to the foreground by clicking on it. Click on the wires connected to
the input and output pins. Notice that these wires become highlighted once selected. Go back to the
Analog Artist Environment window and now there are two entries in the output section of the
window as shown below. These are the signals that will be displayed.

To start the simulations click on the button showing the traffic light (with green). If there are no
errors the simulation will run.
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After simulations are done the waveform window opens and displays the signals Vin and Vout as
shown.
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There exists a number of ways to edit the traces for clarity and preferential labeling once the
simulations are completed and the traces displayed. You can use the crosshair to make
measurements on the waveforms.



The netlist generated by the simulator can be viewed by going to
Simulation—Netlist—Display Final Netlist
It is a good idea to save the state of simulation, if you want to redo any of the simulations without
having to re-enter everything from scratch. To save the current state of the simulation, in the Analog

Artist Environment window go to Session—S8ave state. In the window that opens, enter the name
for the state of simulation to be saved. The default name is Statel.
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To redo a saved simulation, follow this procedure. When the Analog Artist Environment window

opens, go to Setup—Simulation.

From the window that opens select the simulation type as Spectre (if it is not already defaulted to)
from the drop down menu. Finish by clicking OK. Then go to Session—ILoad state. A window as

follows opens.
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From this select the state you want to load and finish by clicking OIK. The previously saved state of
simulation is loaded and you can make any changes if needed and continue with simulation.

Creating a Symbol




To create a symbol for the schematic go to Design—Create Cellview—From cellview...
The following window appears.
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Verify the name of the library and the cell name for which you are creating the symbol and proceed
by clicking OK.

A new window appears, with a symbol for your schematic. In the present case it’s the symbol for the
inverter.
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Now this symbol can be used as a component in any other schematic.

If any changes are made to the schematic, the symbol must be recreated (modified), following
the same procedure.



Measuring the current and power of circuit

Insert the vsource in analogLib between circuit and vdd. Make source type dc and put 0V in DC voltage.
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In Analog Design Environment, Go to outputs->to be plotted-> select on schematic and select the node
between vsource and vdd.

Run the simulation and you can see the current plot. To measure the current go to tools->calculator.
Select wave and click the current wave you want to measure. Then select average in calculator and click
Eval button. You will get the current.
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Now you can have the power (P = 1xV) by using the current and vdd value.



Measuring the transistor |-V

Draw a schematic as in the following figure. You can use vsource in analogLib for voltage source.
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Make source type dc and put VDS V in DC voltage.
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Click check and save open the Analog Design Environment. In Analog Design Environment, go to menu
setup -> Model Libraries. Click on Browse and select the file named modelFiles.scs. Click Ok and the
Add tab. Go back to Analog Design Environment and click the Edit variables button and click the Copy
from button to get VDS value from schematic design.
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Define any value which is not important for the current simulation.
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After this, go to Analyses-> choose and select the option choose. In this window, select dc and follow the
setting from the figure.
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In Analog Design Environment, go to output -> to be plotted -> select on schematic and press the drain.
Also go to output -> to be saved -> select on schematic. This will save and plot the drain current. Now
click netlist and run. You can see the I-V plot.
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